Google Ads and SA360 Delays

Incident Report for Invoca

Resolved

Google Ads and SA360 continue to operate as expected.
Posted Jul 03, 2025 - 08:39 PDT

Update

Error responses related to GoogleAds and Google SA360 have subsided, in addition to Google marking the issue resolved on their status page. We will continue to monitor through the evening and into the morning to ensure we continue to see services operating as expected.
Posted Jul 02, 2025 - 21:26 PDT

Monitoring

Error responses related to GoogleAds and Google SA360 have subsided, in addition to Google marking the issue resolved on their status page. We will continue to monitor through the evening and into the morning to ensure we continue to see services operating as expected.
Posted Jul 02, 2025 - 21:25 PDT

Update

Google is having some minor issues related to the Google Ads and SA360 integrations. Impact at this time is delays in reported conversions. We are continuing to monitor the issue with Google.
Posted Jul 02, 2025 - 14:54 PDT

Investigating

Google is having some minor issues related to the Google Ads and SA360 integrations. Impact at this time is delays in reported conversions. We are continuing to monitor the issue with Google.
Posted Jul 02, 2025 - 14:53 PDT
This incident affected: Integrations (Google Ads).