Google SIP Routing Issue - 9/12/24
Incident Report for Invoca
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 05:58 PDT
Monitoring
We have seen no call failures since 9:24pm ET. We will continue to monitor this issue into tomorrow.
Posted Sep 12, 2024 - 20:19 PDT
Update
Google is continuing to resolve the issue. There have been recent improvements in successfully connecting Google Call Extension calls to their destinations, with 77% of their calls connecting over the last hour.
Posted Sep 12, 2024 - 18:03 PDT
Identified
Continued impact of ~40% of all Google Inbound GCE Calls not connecting. Google has stated a fix is being implemented shortly, but no specific ETA at the moment.
Posted Sep 12, 2024 - 15:00 PDT
Investigating
To not disrupt any currently connected calls, we have elected to not swap Google SIP calls to route over to PSTN at this time. Currently, all calls routing over Google SIP are failing to connect to their destination.
Posted Sep 12, 2024 - 14:03 PDT
Identified
We have identified an issue with Google's ability to successfully connect calls to Invoca over SIP. This primarily impacts Google Call Extension calls from connecting to Invoca tracking numbers. Google has identified the root cause and is working to resolve the issue. In the meantime, we are purposefully adjusting our routing methodology for all Google SIP calls to route over PSTN. This will ensure that calls made directly from Google ads continue to connect but will result in a loss of attribution data for any Google Call Extension calls.
Posted Sep 12, 2024 - 13:48 PDT
This incident affected: Call Routing and Integrations (Google Ads).